What’s Vulnerable › Vulnerabilities
CVE-2022-0983
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-25 · updated 2026-06-17
- Weakness: CWE-89
Description
An SQL injection risk was identified in Badges code relating to configuring criteria. Access to the relevant capability was limited to teachers and managers by default.
Affected products
- Fedoraproject Extra Packages For Enterprise Linux: 7.0
- Fedoraproject Fedora: 35, 36
- Moodle: from 3.9.0 before 3.9.13; from 3.10.0 before 3.10.10; from 3.11.0 before 3.11.6 — fixed in 3.10.10, 3.11.6, 3.9.13
How to fix
Upgrade to a fixed version: Moodle 3.10.10, 3.11.6, 3.9.13. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2064119
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G4GRMWBGHOJMFXMTORECQNULJK7ZJJ6Y/
- https://bugzilla.redhat.com/show_bug.cgi?id=2064119
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G4GRMWBGHOJMFXMTORECQNULJK7ZJJ6Y/
Get alerted when CVE-2022-0983 or the next vulnerability affects your stack