What’s Vulnerable › Vulnerabilities
CVE-2022-0984
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-29 · updated 2026-06-17
- Weakness: CWE-863
Description
Users with the capability to configure badge criteria (teachers and managers by default) were able to configure course badges with profile field criteria, which should only be available for site badges.
Affected products
- Fedoraproject Fedora: 34, 35, 36
- Moodle: from 3.9.0 before 3.9.13; from 3.10.0 before 3.10.10; from 3.11.0 before 3.11.6 — fixed in 3.10.10, 3.11.6, 3.9.13
- Red Hat Enterprise Linux: 7.0
How to fix
Upgrade to a fixed version: Moodle 3.10.10, 3.11.6, 3.9.13. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2064118
- https://bugzilla.redhat.com/show_bug.cgi?id=2064118
Get alerted when CVE-2022-0984 or the next vulnerability affects your stack