What’s Vulnerable › Vulnerabilities
CVE-2022-0985
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-29 · updated 2026-06-17
- Weakness: CWE-287
Description
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
Affected products
- Moodle: before 3.9.13; from 3.10.0 before 3.10.10; from 3.11.0 before 3.11.6 — fixed in 3.10.10, 3.11.6, 3.9.13
How to fix
Upgrade to a fixed version: Moodle 3.10.10, 3.11.6, 3.9.13. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2064117
- https://bugzilla.redhat.com/show_bug.cgi?id=2064117
Get alerted when CVE-2022-0985 or the next vulnerability affects your stack