What’s Vulnerable › Vulnerabilities
CVE-2022-0992: SiteGround Security <= 1.2.5 - Authentication Bypass via 2FA Setup
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-19 · updated 2026-06-17
- Weakness: CWE-288
Description
The SiteGround Security plugin for WordPress is vulnerable to authentication bypass that allows unauthenticated users to log in as administrative users due to missing identity verification on initial 2FA set-up that allows unauthenticated and unauthorized users to configure 2FA for pending accounts. Upon successful configuration, the attacker is logged in as that user without access to a username/password pair which is the expected first form of authentication. This affects versions up to, and including, 1.2.5.
Affected products
- SiteGround Security Optimizer: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: SiteGround Security Optimizer 1.2.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2706302
- https://www.wordfence.com/blog/2022/04/critical-authentication-bypass-vulnerability-patched-in-siteground-security-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6e5c6bf7-a653-4571-9566-574d2bb35c4f?source=cve
- https://plugins.trac.wordpress.org/changeset/2706302
- https://www.wordfence.com/blog/2022/04/critical-authentication-bypass-vulnerability-patched-in-siteground-security-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6e5c6bf7-a653-4571-9566-574d2bb35c4f?source=cve
Get alerted when CVE-2022-0992 or the next vulnerability affects your stack