What’s Vulnerable › Vulnerabilities
CVE-2022-0998
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-30 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow flaw was found in the Linux kernel’s virtio device driver code in the way a user triggers the vhost_vdpa_config_validate function. This flaw allows a local user to crash or potentially escalate their privileges on the system.
Affected products
- Linux kernel: from 5.7 before 5.10.88; from 5.11 before 5.15.11 — fixed in 5.10.88, 5.15.11
- NetApp H300E Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500E Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
How to fix
Upgrade to a fixed version: Linux kernel 5.10.88, 5.15.11. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/04/02/1
- https://lore.kernel.org/netdev/20220123001216.2460383-13-sashal%40kernel.org/
- https://security.netapp.com/advisory/ntap-20220513-0003/
- http://www.openwall.com/lists/oss-security/2022/04/02/1
- https://lore.kernel.org/netdev/20220123001216.2460383-13-sashal%40kernel.org/
- https://security.netapp.com/advisory/ntap-20220513-0003/
Get alerted when CVE-2022-0998 or the next vulnerability affects your stack