What’s Vulnerable › Vulnerabilities
CVE-2022-1001: WP Downgrade < 1.2.3 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Downgrade WordPress plugin before 1.2.3 only perform client side validation of its "WordPress Target Version" settings, but does not sanitise and escape it server side, allowing high privilege users such as admin to perform Cross-Site attacks even when the unfiltered_html capability is disallowed
Affected products
- WP Downgrade | Specific Core Version: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: WP Downgrade | Specific Core Version 1.2.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2696091
- https://wpscan.com/vulnerability/34a7b3cd-e2b5-4891-ab33-af6a2a0eeceb
- https://plugins.trac.wordpress.org/changeset/2696091
- https://wpscan.com/vulnerability/34a7b3cd-e2b5-4891-ab33-af6a2a0eeceb
Get alerted when CVE-2022-1001 or the next vulnerability affects your stack