What’s Vulnerable › Vulnerabilities
CVE-2022-1003: Sysadmin can override existing configs & bypass restrictions like EnableUploads
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-18 · updated 2026-06-17
- Weakness: CWE-268
Description
One of the API in Mattermost version 6.3.0 and earlier fails to properly protect the permissions, which allows the system administrators to combine the two distinct privileges/capabilities in a way that allows them to override certain restricted configurations like EnableUploads.
Affected products
- Mattermost App Framework: before 6.4.0 — fixed in 6.4.0
How to fix
Upgrade to a fixed version: Mattermost App Framework 6.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-1003 or the next vulnerability affects your stack