What’s Vulnerable › Vulnerabilities
CVE-2022-1005: WP Statistics < 13.2.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Statistics WordPress plugin before 13.2.2 does not sanitise the REQUEST_URI parameter before outputting it back in the rendered page, leading to Cross-Site Scripting (XSS) in web browsers which do not encode characters
Affected products
- WP Statistics: before 13.2.2 — fixed in 13.2.2
How to fix
Upgrade to a fixed version: WP Statistics 13.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f37d1d55-10cc-4202-8d16-9ec2128f54f9
- https://wpscan.com/vulnerability/f37d1d55-10cc-4202-8d16-9ec2128f54f9
Get alerted when CVE-2022-1005 or the next vulnerability affects your stack