What’s Vulnerable › Vulnerabilities
CVE-2022-1006: Advanced Booking Calendar < 1.7.1 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-11 · updated 2026-06-17
- Weakness: CWE-89
Description
The Advanced Booking Calendar WordPress plugin before 1.7.1 does not sanitise and escape the id parameter when editing Calendars, which could allow high privilege users such as admin to perform SQL injection attacks
Affected products
- Advanced Booking Calendar: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: Advanced Booking Calendar 1.7.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2695427
- https://wpscan.com/vulnerability/c5569317-b8c8-4524-8375-3e2369bdcc68
- https://plugins.trac.wordpress.org/changeset/2695427
- https://wpscan.com/vulnerability/c5569317-b8c8-4524-8375-3e2369bdcc68
Get alerted when CVE-2022-1006 or the next vulnerability affects your stack