What’s Vulnerable › Vulnerabilities
CVE-2022-1007: Advanced Booking Calendar < 1.7.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced Booking Calendar WordPress plugin before 1.7.1 does not sanitise and escape the room parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting issue
Affected products
- Advanced Booking Calendar: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: Advanced Booking Calendar 1.7.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2695427
- https://wpscan.com/vulnerability/6f5b764b-d13b-4371-9cc5-91204d9d6358
- https://plugins.trac.wordpress.org/changeset/2695427
- https://wpscan.com/vulnerability/6f5b764b-d13b-4371-9cc5-91204d9d6358
Get alerted when CVE-2022-1007 or the next vulnerability affects your stack