What’s Vulnerable › Vulnerabilities
CVE-2022-1009: Smush < 3.9.9 - Admin+ Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Smush WordPress plugin before 3.9.9 does not sanitise and escape a configuration parameter before outputting it back in an admin page when uploading a malicious preset configuration, leading to a Reflected Cross-Site Scripting. For the attack to be successful, an attacker would need an admin to upload a malicious configuration file
Affected products
- Smush – Lazy Load Images, Optimize & Compress Images: before 3.9.9 — fixed in 3.9.9
How to fix
Upgrade to a fixed version: Smush – Lazy Load Images, Optimize & Compress Images 3.9.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bb5af08f-bb19-46a1-a7ac-8381f428c11e
- https://wpscan.com/vulnerability/bb5af08f-bb19-46a1-a7ac-8381f428c11e
Get alerted when CVE-2022-1009 or the next vulnerability affects your stack