What’s Vulnerable › Vulnerabilities
CVE-2022-1022: Cross-site Scripting (XSS) - Stored in chatwoot/chatwoot
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository chatwoot/chatwoot prior to 2.5.0.
Affected products
- chatwoot/chatwoot: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: chatwoot/chatwoot 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/chatwoot/chatwoot/commit/27ddd77a1b621f503fe89a436a49f44b0b1204b5
- https://huntr.dev/bounties/2e4ac6b5-7357-415d-9633-65c636b20e94
- https://github.com/chatwoot/chatwoot/commit/27ddd77a1b621f503fe89a436a49f44b0b1204b5
- https://huntr.dev/bounties/2e4ac6b5-7357-415d-9633-65c636b20e94
Get alerted when CVE-2022-1022 or the next vulnerability affects your stack