What’s Vulnerable › Vulnerabilities
CVE-2022-1027: Page Restriction WordPress < 1.2.7 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Restriction WordPress (WP) WordPress plugin before 1.2.7 allows bad actors with administrator privileges to the settings page to inject Javascript code to its settings leading to stored Cross-Site Scripting that will only affect administrator users.
Affected products
- Page Restriction WordPress (WP) – Protect WP Pages/Post: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: Page Restriction WordPress (WP) – Protect WP Pages/Post 1.2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9dbb0d6d-bc84-4b85-8aa5-fa2a8e6fa5e3
- https://wpscan.com/vulnerability/9dbb0d6d-bc84-4b85-8aa5-fa2a8e6fa5e3
Get alerted when CVE-2022-1027 or the next vulnerability affects your stack