What’s Vulnerable › Vulnerabilities
CVE-2022-1028: WordPress Security < 4.2.1 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The WordPress Security Firewall, Malware Scanner, Secure Login and Backup plugin before 4.2.1 does not sanitise and escape some of its settings, leading to malicious users with administrator privileges to store malicious Javascript code leading to Cross-Site Scripting attacks when unfiltered_html is disallowed (for example in multisite setup)
Affected products
- WordPress Security – Firewall, Malware Scanner, Secure Login and Backup: before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: WordPress Security – Firewall, Malware Scanner, Secure Login and Backup 4.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/16fc08ec-8476-4f3c-93ea-6a51ed880dd5
- https://wpscan.com/vulnerability/16fc08ec-8476-4f3c-93ea-6a51ed880dd5
Get alerted when CVE-2022-1028 or the next vulnerability affects your stack