What’s Vulnerable › Vulnerabilities
CVE-2022-1030
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-23 · updated 2026-06-17
- Weakness: CWE-78
Description
Okta Advanced Server Access Client for Linux and macOS prior to version 1.58.0 was found to be vulnerable to command injection via a specially crafted URL. An attacker, who has knowledge of a valid team name for the victim and also knows a valid target host where the user has access, can execute commands on the local system.
Affected products
- Okta Advanced Server Access Client: before 1.58.0 — fixed in 1.58.0
How to fix
Upgrade to a fixed version: Okta Advanced Server Access Client 1.58.0. Check the vendor advisory for mitigations.
References
- https://trust.okta.com/security-advisories/okta-advanced-server-access-client-cve-2022-1030
- https://trust.okta.com/security-advisories/okta-advanced-server-access-client-cve-2022-1030
Get alerted when CVE-2022-1030 or the next vulnerability affects your stack