What’s Vulnerable › Vulnerabilities
CVE-2022-1036: Able to create an account with long password leads to memory corruption / Integer Overflow in microweber/microweber
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-22 · updated 2026-06-17
- Weakness: CWE-190
Description
Able to create an account with long password leads to memory corruption / Integer Overflow in GitHub repository microweber/microweber prior to 1.2.12.
Affected products
- microweber/microweber: before 1.2.12 — fixed in 1.2.12
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.12. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/82be4f0b4729be870ccefdae99a04833f134aa6a
- https://huntr.dev/bounties/db615581-d5a9-4ca5-a3e9-7a39eceaa424
- https://github.com/microweber/microweber/commit/82be4f0b4729be870ccefdae99a04833f134aa6a
- https://huntr.dev/bounties/db615581-d5a9-4ca5-a3e9-7a39eceaa424
Get alerted when CVE-2022-1036 or the next vulnerability affects your stack