What’s Vulnerable › Vulnerabilities
CVE-2022-1043
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-416
Description
A flaw was found in the Linux kernel’s io_uring implementation. This flaw allows an attacker with a local account to corrupt system memory, crash the system or escalate privileges.
Affected products
- Linux kernel: from 5.10.51 before 5.10.61; from 5.11 before 5.13.13 — fixed in 5.10.61, 5.13.13
How to fix
Upgrade to a fixed version: Linux kernel 5.10.61, 5.13.13. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/170834/io_uring-Same-Type-Object-Reuse-Privilege-Escalation.html
- https://access.redhat.com/security/cve/CVE-2022-1043
- https://bugzilla.redhat.com/show_bug.cgi?id=1997328
- https://github.com/torvalds/linux/commit/a30f895ad3239f45012e860d4f94c1a388b36d14
- https://www.zerodayinitiative.com/advisories/ZDI-22-362/
- http://packetstormsecurity.com/files/170834/io_uring-Same-Type-Object-Reuse-Privilege-Escalation.html
- https://access.redhat.com/security/cve/CVE-2022-1043
- https://bugzilla.redhat.com/show_bug.cgi?id=1997328
- https://github.com/torvalds/linux/commit/a30f895ad3239f45012e860d4f94c1a388b36d14
- https://www.zerodayinitiative.com/advisories/ZDI-22-362/
Get alerted when CVE-2022-1043 or the next vulnerability affects your stack