What’s Vulnerable › Vulnerabilities
CVE-2022-1046: Visual Form Builder < 3.0.7 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Visual Form Builder WordPress plugin before 3.0.7 does not sanitise and escape the form's 'Email to' field , which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Visual Form Builder: before 3.0.7 — fixed in 3.0.7
How to fix
Upgrade to a fixed version: Visual Form Builder 3.0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a1ae4512-0b5b-4f36-8334-14633bf24758
- https://wpscan.com/vulnerability/a1ae4512-0b5b-4f36-8334-14633bf24758
Get alerted when CVE-2022-1046 or the next vulnerability affects your stack