What’s Vulnerable › Vulnerabilities
CVE-2022-1047: Themify - Post Type Builder Search Addon < 1.4.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Themify Post Type Builder Search Addon WordPress plugin before 1.4.0 does not properly escape the current page URL before reusing it in a HTML attribute, leading to a reflected cross site scripting vulnerability.
Affected products
- themify-ptb-search: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: themify-ptb-search 1.4.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/078bd5f6-64f7-4665-825b-9fd0c2b7b91b
- https://wpscan.com/vulnerability/078bd5f6-64f7-4665-825b-9fd0c2b7b91b
Get alerted when CVE-2022-1047 or the next vulnerability affects your stack