What’s Vulnerable › Vulnerabilities
CVE-2022-1048
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-29 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free flaw was found in the Linux kernel’s sound subsystem in the way a user triggers concurrent calls of PCM hw_params. The hw_free ioctls or similar race condition happens inside ALSA PCM for other ioctls. This flaw allows a local user to crash or potentially escalate their privileges on the system.
Affected products
- Debian Linux: 10.0, 11.0
- Linux kernel: from 2.6.12 before 4.14.279; from 4.15 before 4.19.243; from 4.20 before 5.4.193; from 5.5 before 5.10.109; from 5.11 before 5.15.32; from 5.16 before 5.16.18 — fixed in 4.14.279, 4.19.243, 5.10.109, 5.15.32, 5.16.18, 5.4.193
- NetApp H300E Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500E Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.279, 4.19.243, 5.10.109, 5.15.32. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2066706
- https://lore.kernel.org/lkml/20220322170720.3529-5-tiwai%40suse.de/T/#m1d3b791b815556012c6be92f1c4a7086b854f7f3
- https://security.netapp.com/advisory/ntap-20220629-0001/
- https://www.debian.org/security/2022/dsa-5127
- https://www.debian.org/security/2022/dsa-5173
- https://bugzilla.redhat.com/show_bug.cgi?id=2066706
- https://lore.kernel.org/lkml/20220322170720.3529-5-tiwai%40suse.de/T/#m1d3b791b815556012c6be92f1c4a7086b854f7f3
- https://security.netapp.com/advisory/ntap-20220629-0001/
- https://www.debian.org/security/2022/dsa-5127
- https://www.debian.org/security/2022/dsa-5173
Get alerted when CVE-2022-1048 or the next vulnerability affects your stack