What’s Vulnerable › Vulnerabilities
CVE-2022-1050
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-29 · updated 2026-06-17
- Weakness: CWE-416
Description
A flaw was found in the QEMU implementation of VMWare's paravirtual RDMA device. This flaw allows a crafted guest driver to execute HW commands when shared buffers are not yet allocated, potentially leading to a use-after-free condition.
Affected products
- QEMU: before 2.20.1 — fixed in 2.20.1
How to fix
Upgrade to a fixed version: QEMU 2.20.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2069625
- https://lists.debian.org/debian-lts-announce/2023/03/msg00013.html
- https://bugzilla.redhat.com/show_bug.cgi?id=2069625
- https://lists.debian.org/debian-lts-announce/2023/03/msg00013.html
Get alerted when CVE-2022-1050 or the next vulnerability affects your stack