What’s Vulnerable › Vulnerabilities
CVE-2022-1068: Modbus Tools Modbus Slave Stack-Based Buffer Overflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-121
Description
Modbus Tools Modbus Slave (versions 7.4.2 and prior) is vulnerable to a stack-based buffer overflow in the registration field. This may cause the program to crash when a long character string is used.
Affected products
- Modbus Tools Modbus Slave: before 7.4.3 — fixed in 7.4.3
How to fix
Upgrade to a fixed version: Modbus Tools Modbus Slave 7.4.3. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-088-04
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-088-04
Get alerted when CVE-2022-1068 or the next vulnerability affects your stack