What’s Vulnerable › Vulnerabilities

CVE-2022-1100

Description

A potential DOS vulnerability was discovered in GitLab CE/EE affecting all versions from 13.1 prior to 14.7.7, 14.8.0 prior to 14.8.5, and 14.9.0 prior to 14.9.2. The api to update an asset as a link from a release had a regex check which caused exponential number of backtracks for certain user supplied values resulting in high CPU usage.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.7.7, 14.8.5, 14.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-1100 or the next vulnerability affects your stack