What’s Vulnerable › Vulnerabilities
CVE-2022-1116
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-17 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer Overflow or Wraparound vulnerability in io_uring of Linux Kernel allows local attacker to cause memory corruption and escalate privileges to root. This issue affects: Linux Kernel versions prior to 5.4.189; version 5.4.24 and later versions.
Affected products
- Linux kernel: from 5.4.24 before 5.4.189 — fixed in 5.4.189
- NetApp H300S Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
How to fix
Upgrade to a fixed version: Linux kernel 5.4.189. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/167386/Kernel-Live-Patch-Security-Notice-LSN-0086-1.html
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/fs/io_uring.c?h=v5.4.189&id=1a623d361ffe5cecd4244a02f449528416360038
- https://kernel.dance/#1a623d361ffe5cecd4244a02f449528416360038
- https://security.netapp.com/advisory/ntap-20220629-0004/
- http://packetstormsecurity.com/files/167386/Kernel-Live-Patch-Security-Notice-LSN-0086-1.html
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/fs/io_uring.c?h=v5.4.189&id=1a623d361ffe5cecd4244a02f449528416360038
- https://kernel.dance/#1a623d361ffe5cecd4244a02f449528416360038
- https://security.netapp.com/advisory/ntap-20220629-0004/
Get alerted when CVE-2022-1116 or the next vulnerability affects your stack