What’s Vulnerable › Vulnerabilities
CVE-2022-1117
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-552
Description
A vulnerability was found in fapolicyd. The vulnerability occurs due to an assumption on how glibc names the runtime linker, a build time regular expression may not correctly detect the runtime linker. The consequence is that the pattern detection for applications launched by the run time linker may fail to detect the pattern and allow execution.
Affected products
- fapolicyd: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: fapolicyd 1.1.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-1117
- https://bugzilla.redhat.com/show_bug.cgi?id=2066904
- https://bugzilla.redhat.com/show_bug.cgi?id=2068171
- https://github.com/linux-application-whitelisting/fapolicyd/commit/38a942613f93824c53164730b2b7a2f75b8cd263
- https://access.redhat.com/security/cve/CVE-2022-1117
- https://bugzilla.redhat.com/show_bug.cgi?id=2066904
- https://bugzilla.redhat.com/show_bug.cgi?id=2068171
- https://github.com/linux-application-whitelisting/fapolicyd/commit/38a942613f93824c53164730b2b7a2f75b8cd263
Get alerted when CVE-2022-1117 or the next vulnerability affects your stack