What’s Vulnerable › Vulnerabilities
CVE-2022-1123: Leaflet Maps Marker < 3.12.5 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-89
Description
The Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) WordPress plugin before 3.12.5 does not properly sanitize some parameters before inserting them into SQL queries. As a result, high privilege users could perform SQL injection attacks.
Affected products
- Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps): before 3.12.5 — fixed in 3.12.5
How to fix
Upgrade to a fixed version: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) 3.12.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/03e0d4d5-0184-4a15-b8ac-fdc2010e4812
- https://wpscan.com/vulnerability/03e0d4d5-0184-4a15-b8ac-fdc2010e4812
Get alerted when CVE-2022-1123 or the next vulnerability affects your stack