What’s Vulnerable › Vulnerabilities

CVE-2022-1148

Description

Improper authorization in GitLab Pages included with GitLab CE/EE affecting all versions from 11.5 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allowed an attacker to steal a user's access token on an attacker-controlled private GitLab Pages website and reuse that token on the victim's other private websites

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.7.7, 14.8.5, 14.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-1148 or the next vulnerability affects your stack