What’s Vulnerable › Vulnerabilities
CVE-2022-1152: Menubar < 5.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Menubar WordPress plugin before 5.8 does not sanitise and escape the command parameter before outputting it back in the response via the menubar AJAX action (available to any authenticated users), leading to a Reflected Cross-Site Scripting
Affected products
- Menubar: before 5.8 — fixed in 5.8
How to fix
Upgrade to a fixed version: Menubar 5.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1c55fda9-e938-4267-be77-a6d73ee46af3
- https://wpscan.com/vulnerability/1c55fda9-e938-4267-be77-a6d73ee46af3
Get alerted when CVE-2022-1152 or the next vulnerability affects your stack