What’s Vulnerable › Vulnerabilities
CVE-2022-1158
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-05 · updated 2026-06-17
- Weakness: CWE-416
Description
A flaw was found in KVM. When updating a guest's page table entry, vm_pgoff was improperly used as the offset to get the page's pfn. As vaddr and vm_pgoff are controllable by user-mode processes, this flaw allows unprivileged local users on the host to write outside the userspace region and potentially corrupt the kernel, resulting in a denial of service condition.
Affected products
- Fedoraproject Fedora: 36
- Linux kernel: from 5.2 before 5.4.189; from 5.5 before 5.10.110; from 5.11 before 5.15.33; from 5.16 before 5.16.19; from 5.17 before 5.17.2 — fixed in 5.10.110, 5.15.33, 5.16.19, 5.17.2, 5.4.189
- Red Hat Enterprise Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: Linux kernel 5.10.110, 5.15.33, 5.16.19, 5.17.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2069793
- https://security.netapp.com/advisory/ntap-20230214-0003/
- https://www.openwall.com/lists/oss-security/2022/04/08/4
- https://bugzilla.redhat.com/show_bug.cgi?id=2069793
- https://security.netapp.com/advisory/ntap-20230214-0003/
- https://www.openwall.com/lists/oss-security/2022/04/08/4
Get alerted when CVE-2022-1158 or the next vulnerability affects your stack