What’s Vulnerable › Vulnerabilities
CVE-2022-1160: heap buffer overflow in get_one_sourceline in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-30 · updated 2026-06-17
- Weakness: CWE-122
Description
heap buffer overflow in get_one_sourceline in GitHub repository vim/vim prior to 8.2.4647.
Affected products
- Fedoraproject Fedora: 34, 35, 36
- vim/vim: before 8.2.4647 — fixed in 8.2.4647
How to fix
Upgrade to a fixed version: vim/vim 8.2.4647. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/2bdad6126778f907c0b98002bfebf0e611a3f5db
- https://huntr.dev/bounties/a6f3222d-2472-439d-8881-111138a5694c
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C2CQXRLBIC4S7JQVEIN5QXKQPYWB5E3J/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RAIQTUO35U5WO2NYMY47637EMCVDJRSL/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/2bdad6126778f907c0b98002bfebf0e611a3f5db
- https://huntr.dev/bounties/a6f3222d-2472-439d-8881-111138a5694c
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C2CQXRLBIC4S7JQVEIN5QXKQPYWB5E3J/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RAIQTUO35U5WO2NYMY47637EMCVDJRSL/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-1160 or the next vulnerability affects your stack