What’s Vulnerable › Vulnerabilities
CVE-2022-1162
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 75.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-798
Description
A hardcoded password was set for accounts registered using an OmniAuth provider (e.g. OAuth, LDAP, SAML) in GitLab CE/EE versions 14.7 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allowing attackers to potentially take over accounts
Affected products
- GitLab: from 14.7.0 before 14.7.7; from 14.8.0 before 14.8.5; from 14.9.0 before 14.9.2 — fixed in 14.7.7, 14.8.5, 14.9.2
How to fix
Upgrade to a fixed version: GitLab 14.7.7, 14.8.5, 14.9.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/166828/Gitlab-14.9-Authentication-Bypass.html
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1162.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/357210
- http://packetstormsecurity.com/files/166828/Gitlab-14.9-Authentication-Bypass.html
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1162.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/357210
Get alerted when CVE-2022-1162 or the next vulnerability affects your stack