What’s Vulnerable › Vulnerabilities
CVE-2022-1171: Vertical scroll recent post < 14.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Vertical scroll recent post WordPress plugin before 14.0 does not sanitise and escape a parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting
Affected products
- Vertical scroll recent post: before 14.0 — fixed in 14.0
How to fix
Upgrade to a fixed version: Vertical scroll recent post 14.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dc5eace4-542f-47e9-b870-a6aae6a38b0f
- https://wpscan.com/vulnerability/dc5eace4-542f-47e9-b870-a6aae6a38b0f
Get alerted when CVE-2022-1171 or the next vulnerability affects your stack