What’s Vulnerable › Vulnerabilities
CVE-2022-1184
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-29 · updated 2026-10-14
- Weakness: CWE-416
Description
A use-after-free flaw was found in fs/ext4/namei.c:dx_insert_block() in the Linux kernel’s filesystem sub-component. This flaw allows a local attacker with a user privilege to cause a denial of service.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04
- Debian Linux: 10.0, 11.0
- Linux kernel: from 2.6.12 (excl.) before 4.9.138; from 4.14 (excl.) before 4.14.283; from 4.19 (excl.) before 4.19.247; from 5.4 (excl.) before 5.4.198; from 5.10 (excl.) before 5.10.121; from 5.15 (excl.) before 5.15.46 — fixed in 4.14.283, 4.19.247, 4.9.138, 5.10.121, 5.15.46, 5.17.14
- Red Hat Enterprise Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.283, 4.19.247, 4.9.138, 5.10.121. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-1184
- https://bugzilla.redhat.com/show_bug.cgi?id=2070205
- https://lists.debian.org/debian-lts-announce/2022/11/msg00001.html
- https://ubuntu.com/security/CVE-2022-1184
- https://www.debian.org/security/2022/dsa-5257
- https://access.redhat.com/security/cve/CVE-2022-1184
- https://bugzilla.redhat.com/show_bug.cgi?id=2070205
- https://lists.debian.org/debian-lts-announce/2022/11/msg00001.html
- https://ubuntu.com/security/CVE-2022-1184
- https://www.debian.org/security/2022/dsa-5257
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2022-1184 or the next vulnerability affects your stack