What’s Vulnerable › Vulnerabilities
CVE-2022-1185
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-787
Description
A denial of service vulnerability when rendering RDoc files in GitLab CE/EE versions 10 to 14.7.7, 14.8.0 to 14.8.5, and 14.9.0 to 14.9.2 allows an attacker to crash the GitLab web application with a maliciously crafted RDoc file
Affected products
- GitLab: from 10.0.0 before 14.7.7; from 14.8.0 before 14.8.5; from 14.9.0 before 14.9.2 — fixed in 14.7.7, 14.8.5, 14.9.2
How to fix
Upgrade to a fixed version: GitLab 14.7.7, 14.8.5, 14.9.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1185.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/349148
- https://hackerone.com/reports/1415071
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1185.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/349148
- https://hackerone.com/reports/1415071
Get alerted when CVE-2022-1185 or the next vulnerability affects your stack