What’s Vulnerable › Vulnerabilities
CVE-2022-1187: WP YouTube Live <= 1.7.21 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The WordPress WP YouTube Live Plugin is vulnerable to Reflected Cross-Site Scripting via POST data found in the ~/inc/admin.php file which allows unauthenticated attackers to inject arbitrary web scripts in versions up to, and including, 1.7.21.
Affected products
- macbookandrew WP YouTube Live: before 1.7.22 — fixed in 1.7.22
How to fix
Upgrade to a fixed version: macbookandrew WP YouTube Live 1.7.22. Check the vendor advisory for mitigations.
References
- https://github.com/macbookandrew/wp-youtube-live/commit/2d8ccb7b12742bf16b5a6068f9fdeeac69bc11b1
- https://plugins.trac.wordpress.org/browser/wp-youtube-live/trunk/inc/admin.php#L355
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2d540b53-5c39-43d5-a055-cc5eccfa65b8?source=cve
- https://github.com/macbookandrew/wp-youtube-live/commit/2d8ccb7b12742bf16b5a6068f9fdeeac69bc11b1
- https://plugins.trac.wordpress.org/browser/wp-youtube-live/trunk/inc/admin.php#L355
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2d540b53-5c39-43d5-a055-cc5eccfa65b8?source=cve
Get alerted when CVE-2022-1187 or the next vulnerability affects your stack