What’s Vulnerable › Vulnerabilities
CVE-2022-1190
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 87.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper handling of user input in GitLab CE/EE versions 8.3 prior to 14.7.7, 14.8 prior to 14.8.5, and 14.9 prior to 14.9.2 allowed an attacker to exploit a stored XSS by abusing multi-word milestone references in issue descriptions, comments, etc.
Affected products
- GitLab: from 8.3.0 before 14.7.7; from 14.8.0 before 14.8.5; from 14.9.0 before 14.9.2 — fixed in 14.7.7, 14.8.5, 14.9.2
How to fix
Upgrade to a fixed version: GitLab 14.7.7, 14.8.5, 14.9.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1190.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/352392
- https://hackerone.com/reports/1455036
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1190.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/352392
- https://hackerone.com/reports/1455036
Get alerted when CVE-2022-1190 or the next vulnerability affects your stack