What’s Vulnerable › Vulnerabilities
CVE-2022-1198
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerabilitity was discovered in drivers/net/hamradio/6pack.c of linux that allows an attacker to crash linux kernel by simulating ax25 device using 6pack driver from user space.
Affected products
- Linux kernel: before 5.17; 5.17-rc1, 5.17-rc2, 5.17-rc3, 5.17-rc4, 5.17-rc5 — fixed in 5.17
- Red Hat Enterprise Linux: 9.0
How to fix
Upgrade to a fixed version: Linux kernel 5.17. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-1198
- https://bugzilla.redhat.com/show_bug.cgi?id=2070689
- https://github.com/torvalds/linux/commit/efe4186e6a1b54bf38b9e05450d43b0da1fd7739
- https://www.openwall.com/lists/oss-security/2022/04/02/3
- https://access.redhat.com/security/cve/CVE-2022-1198
- https://bugzilla.redhat.com/show_bug.cgi?id=2070689
- https://github.com/torvalds/linux/commit/efe4186e6a1b54bf38b9e05450d43b0da1fd7739
- https://www.openwall.com/lists/oss-security/2022/04/02/3
Get alerted when CVE-2022-1198 or the next vulnerability affects your stack