What’s Vulnerable › Vulnerabilities
CVE-2022-1203: Content Mask < 1.8.4.1 - Subscriber+ Arbitrary Options Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-30 · updated 2026-06-17
- Weakness: CWE-352
Description
The Content Mask WordPress plugin before 1.8.4.1 does not have authorisation and CSRF checks in various AJAX actions, as well as does not validate the option to be updated to ensure it belongs to the plugin. As a result, any authenticated user, such as subscriber could modify arbitrary blog options
Affected products
- Content Mask: before 1.8.4.1 — fixed in 1.8.4.1
How to fix
Upgrade to a fixed version: Content Mask 1.8.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3c9969e5-ca8e-4e5d-a482-c6b5c4257820
- https://wpscan.com/vulnerability/3c9969e5-ca8e-4e5d-a482-c6b5c4257820
Get alerted when CVE-2022-1203 or the next vulnerability affects your stack