What’s Vulnerable › Vulnerabilities
CVE-2022-1215
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-02 · updated 2026-06-17
- Weakness: CWE-134
Description
A format string vulnerability was found in libinput
Affected products
- libinput: from 1.10.0 before 1.18.2; from 1.19.0 before 1.19.4; 1.20.0 — fixed in 1.18.2, 1.19.4
How to fix
Upgrade to a fixed version: libinput 1.18.2, 1.19.4. Check the vendor advisory for mitigations.
References
- https://seclists.org/oss-sec/2022/q2/47
- https://security.gentoo.org/glsa/202310-14
- https://seclists.org/oss-sec/2022/q2/47
- https://security.gentoo.org/glsa/202310-14
Get alerted when CVE-2022-1215 or the next vulnerability affects your stack