What’s Vulnerable › Vulnerabilities
CVE-2022-1220: FoxyShop < 4.8.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The FoxyShop WordPress plugin before 4.8.2 does not sanitise and escape a parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting
Affected products
- FoxyShop: before 4.8.2 — fixed in 4.8.2
How to fix
Upgrade to a fixed version: FoxyShop 4.8.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/eb58f43e-4304-40e7-9e0f-d0d6fe049724
- https://wpscan.com/vulnerability/eb58f43e-4304-40e7-9e0f-d0d6fe049724
Get alerted when CVE-2022-1220 or the next vulnerability affects your stack