What’s Vulnerable › Vulnerabilities
CVE-2022-1226: Cross-site Scripting (XSS) in phpipam/phpipam
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
A Cross-Site Scripting (XSS) vulnerability in phpipam/phpipam versions prior to 1.4.7 allows attackers to execute arbitrary JavaScript code in the browser of a victim. This vulnerability affects the import Data set feature via a spreadsheet file upload. The affected endpoints include import-vlan-preview.php, import-subnets-preview.php, import-vrf-preview.php, import-ipaddr-preview.php, import-devtype-preview.php, import-devices-preview.php, and import-l2dom-preview.php. The vulnerability can be exploited by uploading a specially crafted spreadsheet file containing malicious JavaScript payloads, which are then executed in the context of the victim's browser. This can lead to defacement of websites, execution of malicious JavaScript code, stealing of user cookies, and unauthorized access to user accounts.
Affected products
- phpipam/phpipam: before 1.4.7 — fixed in 1.4.7
How to fix
Upgrade to a fixed version: phpipam/phpipam 1.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/phpipam/phpipam/commit/50e36b9e4fff5eaa51dc6e42bc684748da378002
- https://huntr.com/bounties/3fdcf653-fe26-4592-94a1-98ce664618ec
Get alerted when CVE-2022-1226 or the next vulnerability affects your stack