What’s Vulnerable › Vulnerabilities
CVE-2022-1228: Opensea < 1.0.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Opensea WordPress plugin before 1.0.3 does not sanitize and escape some of its settings, like its "Referer address" field, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Opensea Project Opeansea: before 1.0.3 — fixed in 1.0.3
How to fix
Upgrade to a fixed version: Opensea Project Opeansea 1.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ef6830c0-e933-4e62-8321-011d91f9cfea
- https://wpscan.com/vulnerability/ef6830c0-e933-4e62-8321-011d91f9cfea
Get alerted when CVE-2022-1228 or the next vulnerability affects your stack