What’s Vulnerable › Vulnerabilities
CVE-2022-1234: XSS in livehelperchat in livehelperchat/livehelperchat
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-06 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS in livehelperchat in GitHub repository livehelperchat/livehelperchat prior to 3.97. This vulnerability has the potential to deface websites, result in compromised user accounts, and can run malicious code on web pages, which can lead to a compromise of the user’s device.
Affected products
- livehelperchat/livehelperchat: before 3.97 — fixed in 3.97
How to fix
Upgrade to a fixed version: livehelperchat/livehelperchat 3.97. Check the vendor advisory for mitigations.
References
- https://github.com/livehelperchat/livehelperchat/commit/a09aa0d793818dc4cae78ac4bcfb557d4fd2a30d
- https://huntr.dev/bounties/0d235252-0882-4053-85c1-b41b94c814d4
- https://github.com/livehelperchat/livehelperchat/commit/a09aa0d793818dc4cae78ac4bcfb557d4fd2a30d
- https://huntr.dev/bounties/0d235252-0882-4053-85c1-b41b94c814d4
Get alerted when CVE-2022-1234 or the next vulnerability affects your stack