What’s Vulnerable › Vulnerabilities
CVE-2022-1237: Improper Validation of Array Index in radareorg/radare2
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-06 · updated 2026-06-17
- Weakness: CWE-129
Description
Improper Validation of Array Index in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is heap overflow and may be exploitable. For more general description of heap buffer overflow, see [CWE](https://cwe.mitre.org/data/definitions/122.html).
Affected products
- radareorg/radare2: before 5.6.8 — fixed in 5.6.8
How to fix
Upgrade to a fixed version: radareorg/radare2 5.6.8. Check the vendor advisory for mitigations.
References
- https://github.com/radareorg/radare2/commit/2d782cdaa2112c10b8dd5e7a93c134b2ada9c1a6
- https://huntr.dev/bounties/ad3c9c4c-76e7-40c8-bd4a-c095acd8bb40
- https://github.com/radareorg/radare2/commit/2d782cdaa2112c10b8dd5e7a93c134b2ada9c1a6
- https://huntr.dev/bounties/ad3c9c4c-76e7-40c8-bd4a-c095acd8bb40
Get alerted when CVE-2022-1237 or the next vulnerability affects your stack