What’s Vulnerable › Vulnerabilities
CVE-2022-1239: HubSpot < 8.8.15 - Contributor+ Blind SSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-02 · updated 2026-06-17
- Weakness: CWE-918
Description
The HubSpot WordPress plugin before 8.8.15 does not validate the proxy URL given to the proxy REST endpoint, which could allow users with the edit_posts capability (by default contributor and above) to perform SSRF attacks
Affected products
- hubspotdev HubSpot All-In-One Marketing – Forms, Popups, Live Chat: before 8.8.15 — fixed in 8.8.15
How to fix
Upgrade to a fixed version: hubspotdev HubSpot All-In-One Marketing – Forms, Popups, Live Chat 8.8.15. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4ad2bb96-87a4-4590-a058-b03b33d2fcee
- https://wpscan.com/vulnerability/4ad2bb96-87a4-4590-a058-b03b33d2fcee
Get alerted when CVE-2022-1239 or the next vulnerability affects your stack