What’s Vulnerable › Vulnerabilities
CVE-2022-1250: LifterLMS PayPal < 1.4.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The LifterLMS PayPal WordPress plugin before 1.4.0 does not sanitise and escape some parameters from the payment confirmation page before outputting them back in the page, leading to a Reflected Cross-Site Scripting issue
Affected products
- chrisbadgett LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: chrisbadgett LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes 1.4.0. Check the vendor advisory for mitigations.
References
- https://make.lifterlms.com/2022/04/04/lifterlms-paypal-version-1-4-0/
- https://wpscan.com/vulnerability/1f8cb0b9-7447-44db-8d13-292db5b17718
- https://make.lifterlms.com/2022/04/04/lifterlms-paypal-version-1-4-0/
- https://wpscan.com/vulnerability/1f8cb0b9-7447-44db-8d13-292db5b17718
Get alerted when CVE-2022-1250 or the next vulnerability affects your stack