What’s Vulnerable › Vulnerabilities
CVE-2022-1278
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-13 · updated 2026-06-17
- Weakness: CWE-1188
Description
A flaw was found in WildFly, where an attacker can see deployment names, endpoints, and any other data the trace payload may contain.
Affected products
- RedHat Amq: 2.0
- AMQ: all versions
- RedHat Integration Camel K: all versions
- RedHat Integration Service Registry: all versions
- RedHat Jboss A-Mq: 7
- RedHat Jboss Enterprise Application Platform Expansion Pack: all versions
- Red Hat Single Sign-On: 7.0
- Wildfly: before 27.0.0 — fixed in 27.0.0
How to fix
Upgrade to a fixed version: Wildfly 27.0.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2073401
- https://bugzilla.redhat.com/show_bug.cgi?id=2073401
Get alerted when CVE-2022-1278 or the next vulnerability affects your stack