What’s Vulnerable › Vulnerabilities
CVE-2022-1321: miniOrange's Google Authenticator < 5.5.6 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The miniOrange's Google Authenticator WordPress plugin before 5.5.6 does not sanitise and escape some of its settings, leading to malicious users with administrator privileges to store malicious Javascript code leading to Cross-Site Scripting attacks when unfiltered_html is disallowed (for example in multisite setup)
Affected products
- Google Authenticator: before 5.5.6 — fixed in 5.5.6
How to fix
Upgrade to a fixed version: Google Authenticator 5.5.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b8784995-0deb-4c83-959f-52b37881e05c
- https://wpscan.com/vulnerability/b8784995-0deb-4c83-959f-52b37881e05c
Get alerted when CVE-2022-1321 or the next vulnerability affects your stack