What’s Vulnerable › Vulnerabilities
CVE-2022-1327: Image Gallery - Grid Gallery < 1.1.6 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Image Gallery WordPress plugin before 1.1.6 does not sanitize and escape some of its Image fields, which could allow high-privileged users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Image Gallery – Grid Gallery: before 1.1.6 — fixed in 1.1.6
How to fix
Upgrade to a fixed version: Image Gallery – Grid Gallery 1.1.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6b71eb38-0a4a-49d1-96bc-84bbe675be1e
- https://wpscan.com/vulnerability/6b71eb38-0a4a-49d1-96bc-84bbe675be1e
Get alerted when CVE-2022-1327 or the next vulnerability affects your stack