What’s Vulnerable › Vulnerabilities
CVE-2022-1328
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-14 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer Overflow in uudecoder in Mutt affecting all versions starting from 0.94.13 before 2.2.3 allows read past end of input line
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 36
- mutt: from 0.94.13 before 2.2.3 — fixed in 2.2.3
How to fix
Upgrade to a fixed version: mutt 2.2.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1328.json
- https://gitlab.com/muttmua/mutt/-/commit/e5ed080c00e59701ca62ef9b2a6d2612ebf765a5
- https://gitlab.com/muttmua/mutt/-/issues/404
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1328.json
- https://gitlab.com/muttmua/mutt/-/commit/e5ed080c00e59701ca62ef9b2a6d2612ebf765a5
- https://gitlab.com/muttmua/mutt/-/issues/404
Get alerted when CVE-2022-1328 or the next vulnerability affects your stack